1st May 2018

Storage Storage performance degradation

Our monitoring detected latency on parts of our storage platform. Engineers are currently investigating the issue. Customers may experience degraded performance on some services until the issue has been resolved.

Update (23:22): Some servers are currently being rebooted
Update (23:38): All servers have been rebooted. Our apologies for the inconvenience. We will take necessary steps to prevent this in the future.